CADPL-Pack-v1

Witaj w świecie CADPL

CADPL-Pack-v1 jest zestawem narzędzi programistycznych, tworzonych przez entuzjastów, a zarazem ekspertów w dziedzinie aplikacji pisanych w środowisku CAD.
Językami programowania, które są wykorzystywane przy tworzeniu w/w narzędzi, są:
  • AutoLISP©
  • Visual Lisp©
  • DCL©
  • DIESEL©

Pliki:

Aktualną wersję pakietu, można pobrać stąd: link

Licencja:

Przedstawione funkcje i procedury są oparte na licencji GNU (oryginał).
Więcej informacji przeczytasz również tutaj.

Zastrzeżenia:

Wszystkie zamieszczone na tej stronie nazwy produktów i firm oraz logo są własnością poszczególnych dysponentów.
Nie ponosimy żadnej odpowiedzialności za niewłaściwe wykorzystanie informacji zawartych w programach jak również, za powstałe w wyniku użytkowania programów, ewentualne szkody czy błędy w projektach.
Użytkownik korzysta z oprogramowania CADPL-Pack-v1 wyłącznie na własną odpowiedzialność.

Pomocne Linki:

  • Dyskusja
  • Tool translator
  • Utwórz blok
  • Uzgodnij atrybuty
  • Zapisywanie notatek w rysunku

Kompilacja: 2018-03-08

CADPL-Pack-v1.lsp - http://forum.cad.pl
Open Source 2011 - 2018


CADPL - ACX

ACX

Funkcje ACX:
  • cd:ACX_AddArc - Tworzy obiekt typu ARC
  • cd:ACX_AddCircle - Tworzy obiekt typu CIRCLE
  • cd:ACX_AddLayer - Tworzy nową warstwę
  • cd:ACX_AddLine - Tworzy obiekt typu LINE
  • cd:ACX_AddLWPolyline - Tworzy obiekt typu LWPOLYLINE
  • cd:ACX_AddMText - Tworzy obiekt typu MTEXT
  • cd:ACX_AddTable - Tworzy obiekt typu ACAD_TABLE
  • cd:ACX_AddText - Tworzy obiekt typu TEXT
  • cd:ACX_AddTextStyle - Tworzy nowy styl tekstu
  • cd:ACX_AddViewport - Tworzy obiekt typu VIEWPORT
  • cd:ACX_AddXline - Tworzy obiekt typu XLINE
  • cd:ACX_ADoc - Aktywny dokument
  • cd:ACX_ASpace - Aktywny obszar
  • cd:ACX_Blocks - Kolekcja Blocks
  • cd:ACX_GetProp - Pobiera cechy obiektu VLA/ENAME
  • cd:ACX_Layers - Kolekcja Layers
  • cd:ACX_Layouts - Kolekcja Layouts
  • cd:ACX_LineTypes - Kolekcja LineTypes
  • cd:ACX_LoadLineType - Ładuje definicję linii z pliku .LIN
  • cd:ACX_Model - Obszar modelu
  • cd:ACX_Paper - Obszar papieru
  • cd:ACX_SetProp - Zmienia cechy obiektu VLA/ENAME
  • cd:ACX_TextStyles - Kolekcja TextStyles


cd:ACX_AddArc

Tworzy obiekt typu ARC
(cd:ACX_AddArc Space Pc Radius As Ae ActUcs)
Argumenty:
Space | [VLA-Object] | kolekcja Model/Papier + Blok
Pc | [LIST] | środek łuku
Radius | [REAL] | promień
As | [LIST] | kąt początkowy w radianach
Ae | [LIST] | kąt końcowy w radianach
ActUcs | [T/nil] | dopasuj do aktywnego ucs: nil = nie T = tak
Zwraca:
VLA-Object nowo utworzonego łuku
Przykład:
Polecenie: (cd:ACX_AddArc (cd:ACX_ASpace) '(1 5 0) 5 0 pi T)

#<VLA-OBJECT IAcadArc 22cb79fc>
Powiązane z:
cd:ENT_MakeArc


cd:ACX_AddCircle

Tworzy obiekt typu CIRCLE
(cd:ACX_AddCircle Space Pc Radius ActUcs)
Argumenty:
Layout | [STR] | nazwa arkusza
Pc | [LIST] | środek okręgu
Radius | [REAL] | promień
ActUcs | [T/nil] | dopasuj do aktywnego ucs: nil = nie T = tak
Zwraca:
VLA-Object nowo utworzonego okręgu
Przykład:
Polecenie: (cd:ACX_AddCircle (cd:ACX_ASpace) '(1 5 0) 5 T)

#<VLA-OBJECT IAcadCircle 1d8a54bc>
Powiązane z:
cd:ENT_MakeCircle


cd:ACX_AddLayer

Tworzy nową warstwę
(cd:ACX_AddLayer Name)
Argumenty:
Name [STR] nazwa warstwy
Zwraca:
VLA-Object nowo utworzonej warstwy lub nil
Przykład:
Polecenie: (cd:ACX_AddLayer "ABC")

#<VLA-OBJECT IAcadLayer 1d1f3364>
Powiązane z:
cd:ENT_MakeLayer


cd:ACX_AddLine

Tworzy obiekt typu LINE
(cd:ACX_AddLine Space Ps Pe ActUcs)
Argumenty:
Space | [VLA-Object] | kolekcja Model/Papier + Blok
Ps | [LIST] | punkt początkowy
Pe | [LIST] | punkt końcowy
ActUcs | [T/nil] | dopasuj do aktywnego ucs: nil = nie T = tak
Zwraca:
VLA-Object nowo utworzonej linii
Przykład:
(defun c:TestLine (/ a b)
(command "_.ucs" "x" "32")
(setq a (cd:ACX_AddLine (cd:ACX_ASpace) '(2 4 0) '(10 5 0) nil)
b (cd:ACX_AddLine (cd:ACX_ASpace) '(2 4 0) '(10 5 0) T)
)
(cd:ACX_SetProp a '(("Color" . 1) ("Thickness" . 4.0)))
(cd:ACX_SetProp b '(("Color" . 2) ("Thickness" . 4.0)))
(command ".-view" "_swiso")
(princ)
)

Polecenie: TESTLINE

Sample of ACX_AddLine
Powiązane z:
cd:ENT_MakeLine


cd:ACX_AddLWPolyline

Tworzy obiekt typu LWPOLYLINE
(cd:ACX_AddLWPolyline Space Pts Closed)
Argumenty:
Space | [VLA-Object] | kolekcja Model/Papier
Pts | [LIST] | lista wierzchołków polilinii
Closed | [T/nil] | nil = otwarta T = zamknięta
Zwraca:
VLA-Object nowo utworzonej polilinii
Przykład:
Polecenie: (cd:ACX_AddLWPolyline (cd:ACX_ASpace) (list '(5 5) '(15 5) '(15 10) '(10 10)) nil)

#<VLA-OBJECT IAcadLWPolyline2 16c803a4>
Powiązane z:
cd:ENT_MakeLWPolyline


cd:ACX_AddMText

Tworzy obiekt typu MTEXT
(cd:ACX_AddMText Space Str Pb Width Rot)
Argumenty:
Space | [VLA-Object] | kolekcja Model/Papier + Blok
Str | [STR] | łańcuch tekstowy
Pb | [LIST] | punkt bazowy
Width | [REAL] | szerokość
Rot | [REAL] | kąt obrotu w radianach
Zwraca:
VLA-Object utworzonego tekstu wielowierszowego
Przykład:
Polecenie: (cd:ACX_AddMText (cd:ACX_ASpace) "NEW_TEXT" (getpoint) 1.5 (/ pi 4))

#<VLA-OBJECT IAcadMText 105effbc>


cd:ACX_AddTable

Tworzy obiekt typu ACAD_TABLE
(cd:ACX_AddTable Space Pb Rows Cols RowH ColH)
Argumenty:
Space | [VLA-Object] | kolekcja Model/Papier + Blok
Pb | [LIST] | punkt bazowy tabeli
Rows | [INT] | liczba wierszy
Cols | [INT] | liczba kolumn
RowH | [INT] | wysokość wierszy
ColH | [INT] | szerokość kolumn
Zwraca:
VLA-Object utworzonej tabeli
Przykład:
Polecenie: (cd:ACX_AddTable (cd:ACX_ASpace) (getpoint) 5 5 10 30)

#<VLA-OBJECT IAcadTable 105efd3c>
Powiązane z:
cd:ENT_MakeTable


cd:ACX_AddText

Tworzy obiekt typu TEXT
(cd:ACX_AddText Space Str Pb Height Rot)
Argumenty:
Space | [VLA-Object] | kolekcja Model/Papier + Blok
Str | [STR] | łańcuch tekstowy
Pb | [LIST] | punkt bazowy
Height | [REAL] | wysokość
Rot | [REAL] | kąt obrotu w radianach
Zwraca:
VLA-Object utworzonego tekstu
Przykład:
Polecenie: (cd:ACX_AddText (cd:ACX_ASpace) "NEW_TEXT" (getpoint) 1.5 (/ pi 4))

#<VLA-OBJECT IAcadText 105f03bc>
Powiązane z:
cd:ENT_MakeText


cd:ACX_AddTextStyle

Tworzy nowy styl tekstu
(cd:ACX_AddTextStyle Name)
Argumenty:
Name [STR] nazwa stylu tekstu
Zwraca:
VLA-Object nowo utworzonego stylu lub nil
Przykład:
Polecenie: (cd:ACX_AddTextStyle "ABC")

#<VLA-OBJECT IAcadTextStyle 1d1f39a4>
Powiązane z:
cd:ENT_MakeTextStyle


cd:ACX_AddViewport

Tworzy obiekt typu VIEWPORT
(cd:ACX_AddViewport Space Pb Width Height HJust VJust)
Argumenty:
Space | [VLA-Object] | kolekcja Model/Papier + Blok
Pb | [LIST] | punkt bazowy
Width | [REAL] | szerokość rzutni
Height | [REAL] | wysokość rzutni
HJust | [INT] | wyrównanie w poziomie 1 - Lewo 2 - Środek 3 - Prawo
VJust | [INT] | wyrównanie w pionie 1 - Góra 2 - Środek 3 - Dół
Zwraca:
VLA-Object nowo utworzonej rzutni
Przykład:
(cd:ACX_AddViewport (cd:ACX_Paper) (getpoint) 100 200 3 2)

#<VLA-OBJECT IAcadPViewport 000001d199468b18>


cd:ACX_AddXline

Tworzy obiekt typu XLINE
(cd:ACX_AddXline Space Ps Pe)
Argumenty:
Space | [VLA-Object] | kolekcja Model/Papier + Blok
Ps | [LIST] | punkt początkowy
Pe | [LIST/REAL] | punkt końcowy lub kąt w radianach
Zwraca:
VLA-Object nowo utworzonej linii konstrukcyjnej
Przykład:
Polecenie: (cd:ACX_AddXline (cd:ACX_ASpace) (getpoint) (/ pi 4))

#<VLA-OBJECT IAcadXline 1d8a55dc>
Powiązane z:
cd:ENT_MakeXLine


cd:ACX_ADoc

Aktywny dokument
(cd:ACX_ADoc)
Argumenty:
Brak
Zwraca:
VLA-Object aktywnego dokumentu
Przykład:
Polecenie: (cd:ACX_ADoc)

#<VLA-OBJECT IAcadDocument 21747360>


cd:ACX_ASpace

Aktywny obszar
(cd:ACX_ASpace)
Argumenty:
Brak
Zwraca:
VLA-Object aktywnego obszaru
Przykład:
Polecenie: (cd:ACX_ASpace)

#<VLA-OBJECT IAcadModelSpace 1d1f2c84>


cd:ACX_Blocks

Kolekcja Blocks
(cd:ACX_Blocks)
Argumenty:
Brak
Zwraca:
VLA-Object kolekcji bloków
Przykład:
Polecenie: (cd:ACX_Blocks)

#<VLA-OBJECT IAcadBlocks 140a2fbc>


cd:ACX_GetProp

Pobiera cechy obiektu VLA/ENAME
(cd:ACX_GetProp Obj Lst)
Argumenty:
Obj | [ENAME/VLA-Object] | obiekt VLA lub entycja
Lst | [LIST] | lista cech par kropkowych
Zwraca:
Lista par kropkowych: ((<cecha> . <wartość>) ... )

Wartości:
:vlax-true = 1
:vlax-false = 0
:vlax-null = cecha nie istnieje
Przykład:
Polecenie: (cd:ACX_GetProp (car (entsel)) (list "Area" "Coordinate" "Coordinates" "Bla" "Closed"))

(("Area" . 0.979103) ("Coordinate" . :vlax-false) ("Coordinates" . #<variant 8197 ...>) ("Bla" . :vlax-null) ("Closed" . :vlax-null))
Powiązane z:
cd:ACX_SetProp


cd:ACX_Layers

Kolekcja Layers
(cd:ACX_Layers)
Argumenty:
Brak
Zwraca:
VLA-Object kolekcji warstw
Przykład:
Polecenie: (cd:ACX_Layers)

#<VLA-OBJECT IAcadLayers 1d1f37c4>


cd:ACX_Layouts

Kolekcja Layouts
(cd:ACX_Layouts)
Argumenty:
Brak
Zwraca:
VLA-Object kolekcji Layouts
Przykład:
Polecenie: (cd:ACX_Layouts)

#<VLA-OBJECT IAcadLayouts 1c8d7344>


cd:ACX_LineTypes

Kolekcja LineTypes
(cd:ACX_LineTypes)
Argumenty:
Brak
Zwraca:
VLA-Object kolekcji typów linii
Przykład:
Polecenie: (cd:ACX_LineTypes)

#<VLA-OBJECT IAcadLineTypes 0dba7b54>


cd:ACX_LoadLineType

Ładuje definicje rodzaju linii z pliku .LIN
(cd:ACX_LoadLineType Name File)
Argumenty:
Name | [STR] | nazwa warstwy
File | [STR] | nazwa pliku .LIN
Zwraca:
nil
Przykład:
Polecenie: (cd:ACX_LoadLineType "HIDDEN" "acadiso.lin")

nil


cd:ACX_Model

Obszar modelu
(cd:ACX_Model)
Argumenty:
Brak
Zwraca:
VLA-Object obszaru modelu
Przykład:
Polecenie: (cd:ACX_Model)

#<VLA-OBJECT IAcadModelSpace 1d1f2c84>


cd:ACX_Paper

Obszar papieru
(cd:ACX_Paper)
Argumenty:
Brak
Zwraca:
VLA-Object obszaru papieru
Przykład:
Polecenie: (cd:ACX_Paper)

#<VLA-OBJECT IAcadPaperSpace 1400f6d4>


cd:ACX_SetProp

Zmienia cechy obiektu VLA/ENAME
(cd:ACX_SetProp Obj Lst)
Argumenty:
Obj | [ENAME/VLA-Object] | obiekt VLA lub entycja
Lst | [LIST] | lista cech par kropkowych
Zwraca:
Lista par kropkowych: ((<cecha> . <wartość>) ... )

Wartości:
:vlax-true - cecha poprawna
:vlax-null - cecha nie istnieje
#<%catch-all-apply-error%> - błąd ustawienia cechy
Przykład:
Polecenie: (cd:ACX_SetProp (entlast) '(("LineType" . "BLA")("Color" . 1)("Layer" . "0")))

(("LineType" . #<%catch-all-apply-error%>) ("Color" . :vlax-true) ("Layer" . :vlax-true))
Powiązane z:
cd:ACX_GetProp


cd:ACX_TextStyles

Kolekcja TextStyles
(cd:ACX_TextStyles)
Argumenty:
Brak
Zwraca:
VLA-Object kolekcji stylów tekstu
Przykład:
Polecenie: (cd:ACX_TextStyles)

#<VLA-OBJECT IAcadTextStyles 1d1f2f54>


CADPL - BLK

BLK

Funkcje BLK:
  • cd:BLK_AttachXref - Wstawia odnośnik zewnętrzny
  • cd:BLK_GetAttEntity - Lista atrybutów wstawionego bloku
  • cd:BLK_GetAtts - Pobiera wartości wszystkich atrybutów
  • cd:BLK_GetAttsVLA - Pobiera wartości wszystkich atrybutów
  • cd:BLK_GetAttValueVLA - Pobiera wartość atrybutu
  • cd:BLK_GetDynamicProps - Pobiera właściwości bloku dynamicznego
  • cd:BLK_GetDynBlockList - Zwraca listę bloków dynamicznych
  • cd:BLK_GetDynBlockNames - Lista nazw bloków (*U) zależnych od bloku dynamicznego
  • cd:BLK_GetEntity - Lista obiektów w definicji bloku
  • cd:BLK_GetXrefs - Lista odnośników zewnętrznych
  • cd:BLK_InsertBlock - Wstawia blok
  • cd:BLK_IsDynamicInsert - Sprawdza czy wskazany obiekt jest blokiem dynamicznym
  • cd:BLK_SetAttValueVLA - Zmienia wartość atrybutu
  • cd:BLK_SetDynamicProps - Zmienia właściwości bloku dynamicznego


cd:BLK_AttachXref

Wstawia odnośnik zewnętrzny
(cd:BLK_AttachXref Path File Pb Xyz Rot Ovlay)
Argumenty:
Path | [STR] | pełna ścieżka do odnośnika
File | [STR] | nazwa pliku odnośnika
Pb | [LIST] | punkt wstawienia
Xyz | [LIST/nil] | LISTA = lista współczynników skali XYZ nil = X=Y=Z=1.0
Rot | [REAL/nil] | REAL = kąt obrotu w radianach nil = kąt=0.0
Ovlay | [BOOL] | typ odnośnika nil = dołącz T = nałóż
Zwraca:
VLA-Object wstawionego odnośnika lub nil
Przykład:
Polecenie: (cd:BLK_AttachXref "d:\\" "Angle.dwg" '(10 5 0) '(2 2 2) 45 T)

#<VLA-OBJECT IAcadExternalReference2 0000019df7a9aad8>


cd:BLK_GetAttEntity

Lista atrybutów wstawionego bloku
(cd:BLK_GetAttEntity Ename)
Argumenty:
Ename [ENAME] nazwa entycji
Zwraca:
Listę (Entity-name ... ) lub nil
Przykład:
Polecenie: (cd:BLK_GetAttEntity (car (entsel)))

(<Entity name: 7ef5aae0> <Entity name: 7ef5aae8>)


cd:BLK_GetAtts

Pobiera wartości wszystkich atrybutów
(cd:BLK_GetAtts Ename)
Argumenty:
Ename [ENAME] nazwa entycji
Zwraca:
Lista par kropkowych: ((<atrybut> . <wartość>) ... ) lub nil
Przykład:
Polecenie: (cd:BLK_GetAtts (car (entsel)))

(("ATR_0" . "13") ("ATR_1" . "69") ("ATR_2" . "250") ("ATR_3" . "HELLO WORLD"))
Powiązane z:
cd:BLK_GetAttsVLA


cd:BLK_GetAttsVLA

Pobiera wartości wszystkich atrybutów
(cd:BLK_GetAttsVLA Obj)
Argumenty:
Obj [VLA-Object] obiekt VLA
Zwraca:
Lista par kropkowych: ((<atrybut> . <wartość>) ... ) lub nil
Przykład:
Polecenie: (cd:BLK_GetAttsVLA (vlax-ename->vla-object (car (entsel))))

(("ATR_0" . "13") ("ATR_1" . "69") ("ATR_2" . "250") ("ATR_3" . "HELLO WORLD"))
Powiązane z:
cd:BLK_GetAtts


cd:BLK_GetAttValueVLA

Pobiera wartość atrybutu
(cd:BLK_GetAttValueVLA Obj Tag)
Argumenty:
Obj | [ENAME/VLA-Object] | obiekt VLA lub entycja
Tag | [STR] | etykieta atrybutu
Zwraca:
Wartość odczytanego atrybutu lub nil
Przykład:
Polecenie: (cd:BLK_GetAttValueVLA (car (entsel)) "VIEW_NUMBER")

"1"
Powiązane z:
cd:BLK_SetAttValueVLA


cd:BLK_GetDynamicProps

Pobiera właściwości bloku dynamicznego
(cd:BLK_GetDynamicProps Obj Origin)
Argumenty:
Obj | [ENAME/VLA-Object] | obiekt VLA lub entycja
Origin | [T/nil] | pokaż właściwość ORIGIN: nil = nie T = tak
Zwraca:
Lista par kropkowych: ((<właściwość> . <wartość>) ... ) lub nil
Przykład:
Polecenie: (cd:BLK_GetDynamicProps (car (entsel)) T)

(("WIDTH" . 6.26844) ("Origin" -3.13422 0.0) ("HEIGHT" . 3.0) ("Origin" 0.0 0.0))
Powiązane z:
cd:BLK_SetDynamicProps


cd:BLK_GetDynBlockList

Zwraca listę bloków dynamicznych
(cd:BLK_GetDynBlockList)
Argumenty:
Brak
Zwraca:
Listę: (<nazwa bloku1> <nazwa bloku2> ... )
Przykład:
Polecenie: (cd:BLK_GetDynBlockList)

("BLOK" "PLAN" "SEKCJA")


cd:BLK_GetDynBlockNames

Lista nazw bloków (*U) zależnych od bloku dynamicznego
(cd:BLK_GetDynBlockNames Name)
Argumenty:
Name [STR] nazwa bloku
Zwraca:
Listę: (<nazwa bloku1> <nazwa bloku2> ... )
Przykład:
Polecenie: (cd:BLK_GetDynBlockNames "ELEVATION TAG")

("ELEVATION TAG" "*U5" "*U6" "*U7")


cd:BLK_GetEntity

Lista obiektów w definicji bloku
(cd:BLK_GetEntity Name Entity)
Argumenty:
Name | [STR] | nazwa bloku
Entity | [STR] | nazwa entycji
Zwraca:
Listę (Entity-name ... ) lub nil
Przykład:
Polecenie: (cd:BLK_GetEntity "NAZWA" "*LINE")

(<Entity name: 7ef04550> <Entity name: 7ef04558>)


cd:BLK_GetXrefs

Lista odnośników zewnętrznych
(cd:BLK_GetXrefs)
Argumenty:
Brak
Zwraca:
Listę odnośników zewnętrznych lub nil
Przykład:
Polecenie: (cd:BLK_GetXrefs)

("XR-PLAN" "XR-DETAL-1" "XR-DETAL-2")


cd:BLK_InsertBlock

Wstawia blok
(cd:BLK_InsertBlock Pb Name Xyz Rot Sup)
Argumenty:
Pb | [LIST] | punkt wstawienia
Name | [STR] | nazwa bloku lub rysunku (bez .dwg)
Xyz | [LIST/nil] | LISTA = lista współczynników skali XYZ nil = X=Y=Z=1.0
Rot | [REAL/nil] | REAL = kąt obrotu w radianach nil = kąt=0.0
Sup | [T/nil] | szukaj w ścieżkach poszukiwań
Zwraca:
VLA-Object wstawionego bloku lub nil
Przykład:
Polecenie: (cd:BLK_InsertBlock '(0 0 0) "d:\\blok" '(2 2 2) 0 T)

#<VLA-OBJECT IAcadBlockReference 13af9ffc>


cd:BLK_IsDynamicInsert

Sprawdza czy wskazany obiekt jest blokiem dynamicznym
(cd:BLK_IsDynamicInsert Obj)
Argumenty:
Obj [ENAME/VLA-Object] obiekt VLA lub entycja
Zwraca:
nil = blok nie jest dynamiczny
T = blok jest dynamiczny
Przykład:
Polecenie: (cd:BLK_IsDynamicInsert (car (entsel)))

T


cd:BLK_SetAttValueVLA

Zmienia wartość atrybutu
(cd:BLK_SetAttValueVLA Obj Tag Value)
Argumenty:
Obj | [ENAME/VLA-Object] | obiekt VLA lub entycja
Tag | [STR] | etykieta atrybutu
Value | [STR] | wartość atrybuty
Zwraca:
Nową wartość atrybutu Value
Przykład:
Polecenie: (cd:BLK_SetAttValueVLA (car (entsel)) "VIEW_NUMBER" "12")

"12"
Powiązane z:
cd:BLK_GetAttValueVLA


cd:BLK_SetDynamicProps

Zmienia właściwości bloku dynamicznego
(cd:BLK_SetDynamicProps Obj Prop Val)
Argumenty:
Obj | [ENAME/VLA-Object] | obiekt VLA lub entycja
Prop | [STR] | właściwość
Val | [REAL/INT/STR] | nowa wartość
Zwraca:
Val lub nil
Przykład:
Polecenie: (cd:BLK_SetDynamicProps (car (entsel)) "Height" 90)

90
Powiązane z:
cd:BLK_GetDynamicProps


CADPL - CAL

CAL

Funkcje CAL:
  • cd:CAL_BitList - Lista bitów liczby całkowitej
  • cd:CAL_Sequence - Tworzy ciąg arytmetyczny


cd:CAL_BitList

Lista bitów liczby całkowitej
(cd:CAL_BitList Number)
Argumenty:
Number [INT] liczba całkowita
Zwraca:
Listę bitów liczby całkowitej
Przykład:
Polecenie: (cd:CAL_BitList 127)

(1 2 4 8 16 32 64)


cd:CAL_Sequence

Tworzy ciąg arytmetyczny
(cd:CAL_Sequence St Le Sp)
Argumenty:
St | [REAL/INT] | liczba początkowa
Le | [REAL/INT] | długość ciągu
Sp | [REAL/INT] | różnica ciągu
Zwraca:
Ciąg arytmetyczny
Przykład:
Polecenie: (cd:CAL_Sequence 1.50 10 0.5)

(1.5 2.0 2.5 3.0 3.5 4.0 4.5 5.0 5.5 6.0)


CADPL - CON

CON

Funkcje CON:
  • cd:CON_All2Str - Zmiana elementów listy na łańcuchy tekstowe
  • cd:CON_ObjConv - Konwertuje obiekt
  • cd:CON_List2Value - Zmiana listy na łańcuch tekstowy
  • cd:CON_Real2Str - Konwertuje liczbę na łańcuch tekstowy
  • cd:CON_TransMatrix - Macierz transformacji układu współrzędnych
  • cd:CON_Value2List - Zmiana łańcucha tekstowego na listę
  • cd:CON_XYZ2Variant - Zamienia listę liczb na 3DPoint (variant)


cd:CON_All2Str

Zmiana elementów listy na łańcuchy tekstowe
(cd:CON_All2Str Lst Mode)
Argumenty:
Lst | [LIST] | lista wejściowa
Mode | [T/nil] | T = jak wynik z funkcji prin1 nil = jak wynik z funkcji princ
Zwraca:
Lista
Przykład:
Polecenie: (cd:CON_All2Str '("A" "B" 1 2 3) nil)

("\"A\"" "\"B\"" "1" "2" "3")

Polecenie: (cd:CON_All2Str '("A" "B" 1 2 3) T)

("A" "B" "1" "2" "3")


cd:CON_ObjConv

Konwertuje obiekt
(cd:CON_ObjConv Obj Format)
Argumenty:
Obj | [ENAME/VLA-Object/STR] | obiekt VLA, entycja lub łańcuch tekstowy
Format | [nil/1/2/3/4] | format wyjściowy: nil = nazwa entycji 1 = obiekt VLA 2 = uchwyt 3 = ObjectID 4 = ObjectIdString
Zwraca:
Patrz opis argumentu Format
Przykład:
Polecenie: (cd:CON_ObjConv (car (entsel)) 2)

"183"


cd:CON_List2Value

Zmiana listy na łańcuch tekstowy
(CON_List2Value Lst)
Argumenty:
Lst [LIST] lista wejściowa
Zwraca:
Łańcuch tekstowy
Przykład:
Polecenie: (cd:CON_List2Value (list 0 1 2 3 5))

"0 1 2 3 5"


cd:CON_Real2Str

Konwertuje liczbę na łańcuch tekstowy
(cd:CON_Real2Str Val Unit Prec)
Argumenty:
Val | [REAL/INT] | liczba do konwersji
Unit | [INT/nil] | jednostki wyjściowe: nil = domyślne, zależne od (getvar "LUNITS") 1 = naukowe 2 = dziesiętne 3 = inżynierskie 4 = architektoniczne 5 = ułamkowe
Prec | [INT/nil] | INT = liczba miejsc po przecinku nil = domyślna, zależna od (getvar "LUPREC")
Zwraca:
Łańcuch tekstowy
Przykład:
Polecenie: (cd:CON_Real2Str 12 2 4)

"12.0000"


cd:CON_TransMatrix

Macierz transformacji układu współrzędnych
(cd:CON_TransMatrix Cs)
Argumenty:
Cs [INT] docelowy układ współrzędnych:
0 = GUW (WCS)
1 = LUW (UCS)
Zwraca:
Listę punktów (macierz)
Przykład:
Polecenie: (cd:CON_TransMatrix 0)

((0.552341 0.261252 0.791623 7.61708) (-0.427575 0.90398 8.32667e-017 6.45376)
(-0.715611 -0.338478 0.61101 1.20467) (0 0 0 1))


cd:CON_Value2List

Zmiana łańcucha tekstowego na listę
(CON_Value2List Val)
Argumenty:
Val [STR] łańcuch tekstowy
Zwraca:
Lista
Przykład:
Polecenie: (cd:CON_Value2List "0 1 2 3 5")

(0 1 2 3 5)


cd:CON_XYZ2Variant

Zamienia listę liczb na 3DPoint (variant)
(CON_XYZ2Variant Lst)
Argumenty:
Lst [LIST] 2 lub 3 elementowa lista liczb
Zwraca:
Listę punktów w postaci Variant
Przykład:
Polecenie: (cd:CON_XYZ2Variant (list 10 2))

#<variant 8197 ...>


CADPL - DCL

DCL

Funkcje DCL:
  • cd:DCL_ChangeColorList - Obsługa listy kolorów
  • cd:DCL_ChangeStringList - Obsługa listy łańcuchów tekstowych
  • cd:DCL_FillColorImage - Wypełnia wycinek "image" kolorem
  • cd:DCL_FillColorList - Wypełnia wycinek "popup_list" listą kolorów
  • cd:DCL_FillStringList - Wypełnia wycinek "popup_list" listą łańcuchów tekstowych
  • cd:DCL_ImgBtnSortIcon - Image_button - ikona sortowania
  • cd:DCL_MsgBox - DCL-owe okno komunikatu
  • cd:DCL_SetList - Wypełnia wycinki "list_box" i "popup_list"
  • cd:DCL_StdEditBoxDialog - Okno dialogowe edit_box
  • cd:DCL_StdListDialog - Okno dialogowe z listą (list_box)


cd:DCL_ChangeColorList

Obsługa listy kolorów
(cd:DCL_ChangeColorList KeyLst KeyImg Lst Color Old)
Argumenty:
KeyLst | [STR] | nazwa wycinka "popup_list"
KeyImg | [STR] | nazwa wycinka "image"
Lst | [LIST] | lista kolorów
Color | [STR] | aktualny kolor
Old | [STR] | poprzedni kolor
Zwraca:
Wartość wybranego koloru jako [STR]
Przykład:
Przykład wykorzystania można zobaczyć w programie DrawingNotes.lsp w funkcji (cd:005_OptionsDialog)


cd:DCL_ChangeStringList

Obsługa listy łańcuchów tekstowych
(cd:DCL_ChangeStringList Key Lst Pos Old Label Func)
Argumenty:
Key | [STR] | nazwa wycinka
Lst | [LIST] | lista
Pos | [INT] | aktualna pozycja na liście
Old | [STR] | poprzednia pozycja na liście
Label | [STR] | etykieta dla pozycji "Nowa..."
Func | [SUBR] | funkcja do obsługi okienka edit_box
Zwraca:
Wybrany łańcuch tekstowy jako [STR]
Przykład:
Przykład wykorzystania można zobaczyć w programie DrawingNotes.lsp w funkcji (cd:005_OptionsDialog)


cd:DCL_FillColorImage

Wypełnia wycinek "image" kolorem
(cd:DCL_FillColorImage Key Color)
Argumenty:
Key | [STR] | nazwa wycinka
Color | [INT] | kolor
Zwraca:
Brak
Przykład:
Przykład wykorzystania można zobaczyć w programie DrawingNotes.lsp w funkcji (cd:005_OptionsDialog)


cd:DCL_FillColorImage

Wypełnia wycinek "popup_list" listą kolorów
(cd:DCL_FillColorImage Key Lst Color)
Argumenty:
Key | [STR] | nazwa wycinka
Lst | [LIST] | lista kolorów
Color | [STR] | aktualny kolor
Zwraca:
Brak
Przykład:
Przykład wykorzystania można zobaczyć w programie DrawingNotes.lsp w funkcji (cd:005_OptionsDialog)


cd:DCL_FillStringList

Wypełnia wycinek "popup_list" listą łańcuchów tekstowych
(cd:DCL_FillStringList Key Lst Str Label)
Argumenty:
Key | [STR] | nazwa wycinka
Lst | [LIST] | lista łańcuchów tekstowych
Str | [STR] | aktualny łańcuch tekstowy
Label | [STR] | etykieta dla pozycji "Nowa..."
Zwraca:
Brak
Przykład:
Przykład wykorzystania można zobaczyć w programie DrawingNotes.lsp w funkcji (cd:005_OptionsDialog)


cd:DCL_ImgBtnSortIcon

Image_button - ikona sortowania
(cd:DCL_ImgBtnSortIcon Key Mode Color)
Argumenty:
Key | [STR] | nazwa wycinka
Mode | [INT] | kierunek sortowania: 0 = rosnąco 1 = malejąco
Color | [INT] | kolor wypełnienia
Zwraca:
Brak
Przykład:
Preview of DCL_ImgBtnSortIcon


cd:DCL_MsgBox

DCL-owe okno komunikatu
(cd:DCL_MsgBox Msg Title Btn DPos Lng)
Argumenty:
Msg | [STR] | komunikat do wyświetlenia
Title | [STR] | tytuł okna
Btn | [0/1/2/3/4/5] | przyciski: 0 = OK 1 = OK i Anuluj 2 = Anuluj 3 = Tak, Nie i Anuluj 4 = Tak i Nie 5 = Zamknij
DPos | [T/nil] | zapamiętanie pozycji okna
Lng | [0/1/nil] | język: 0 = język polski 1 = język angielski nil = ustawienie standardowe
Zwraca:
1 = OK
2 = Anuluj
6 = Tak
7 = Nie
12 = Zamknij
Przykład:
Polecenie: (cd:DCL_MsgBox "Komunikatów 2 liniach" "Uwaga" 4 T 0)
Sample of DCL_MsgBox


cd:DCL_SetList

Wypełnia wycinki "list_box" i "popup_list"
(cd:DCL_SetList Key Lst Pos)
Argumenty:
Key | [STR] | nazwa wycinka
Lst | [LIST] | lista do wypełnienia
Pos | [INT/REAL/STR/nil] | aktualna pozycja na liście
Zwraca:
Brak
Przykład:
Przykład wykorzystania można zobaczyć w programie ToolTranslator.lsp w funkcji (cd:002_Dialog)


cd:DCL_StdEditBoxDialog

Okno dialogowe "edit_box"
(cd:DCL_StdEditBoxDialog Data Title EditTile Width BtnsWidth BtnsLabel DPos Limit)
Argumenty:
Data | [LIST] | lista argumentów (maks. 7) -> (list a b c d e f g) * STR - dowolny łańcuch a = 0 b - INT = rodzaje błędów LIST = rodzaje błędów wraz z komunikatem c - wartość domyślna * STR - zgodny z tablicą/wzorcem a = 1 b - INT = rodzaje błędów LIST = rodzaje błędów wraz z komunikatem c - wartość domyślna d - nazwa tablicy e - wzorzec * INT = 2, REAL = 3 - dowolny łańcuch a = 2,3 b - INT = rodzaje błędów LIST = rodzaje błędów wraz z komunikatem c - wartość domyślna d - wartość minimalna e - wartość maksymalna f - jednostki wyjściowe: nil = domyślne (getvar "LUNITS") 1 = naukowe 2 = dziesiętne 3 = inżynierskie 4 = architektoniczne 5 = ułamkowe g - INT = liczba miejsc po przecinku nil = domyślna (getvar "LUPREC")
Title | [STR/nil] | tytuł okna
EditTile | [STR/nil] | tytuł "edit_box"
Width | [INT] | szerokość
BtnsWidth | [REAL/INT] | szerokość przycisków
BtnsLabel | [LIST] | etykiety przycisków
DPos | [T/nil] | zapamiętanie pozycji okna
Limit | [INT] | limit znaków
Zwraca:
Brak
Przykład:
Polecenie: (cd:DCL_StdEditBoxDialog (list 0 0 "") "Poziom" "New:" 40 13 (list "&Ok" "&Anuluj") T nil)
Preview of DCL_StdEditBoxDialog
Polecenie: (cd:DCL_StdEditBoxDialog (list 1 (list (cons 1 "Wprowadź dane") (cons 2 "Niepoprawna warstwa") (cons 4 "Warstwa występuje w rysunku") (cons 16 "Warstwa nie pasuje do wzorca") ) "" "LAYER" "??-??" ) "Warstwa" "Nowa warstwa: (format ??-??)" 40 13 (list "&Ok" "&Anuluj") T 5 )
Preview of DCL_StdEditBoxDialog2


cd:DCL_StdListDialog

Okno dialogowe z listą (list_box)
(cd:DCL_StdListDialog Data Pos Title ListTitle Width Height Btns MSelect DPos DblClick)
Argumenty:
Data | [LIST] | lista do wyświetlenia
Pos | [INT] | pozycja początkowa na liście
Title | [STR/nil] | tytuł okna
ListTitle | [STR/nil] | tytuł list_box
Width | [INT] | szerokość
Height | [INT] | wysokość
Btns | [0/1/2] | [cancel/ok/ok_cancel] przyciski
MSelect | [T/nil] | dopuszczenie multiple_select
DPos | [T/nil] | zapamiętanie pozycji okna
DblClick | [T/nil] | podwójny klik (wykluczone cancel)
Zwraca:
nil = nic nie wybrano (anulowano)
INT = wybrano jedną pozycję; MSelect=nil
LIST = wybrano kilka pozycji; MSelect=T
Przykład:
Polecenie: (cd:DCL_StdListDialog '("A" "B" "C") 0 "Title" "ListTitle:" 40 15 2 nil T nil)
Sample of DCL_StdListDialog


CADPL - DCT

DCT

Funkcje DCT:
  • cd:DCT_AddDict - Dodaje słownik
  • cd:DCT_AddXrecord - Dodaje Xrecord
  • cd:DCT_GetDict - Pobiera słownik
  • cd:DCT_GetDictList - Pobiera listę słowników "rodzica"
  • cd:DCT_GetExtDict - Pobiera/Tworzy ExtensionDictionary obiektu
  • cd:DCT_GetExtDictVLA - Pobiera/Tworzy ExtensionDictionary obiektu
  • cd:DCT_GetXrecord - Pobiera Xrecord
  • cd:DCT_RemoveDict - Usuwa słownik
  • cd:DCT_ReplaceXrecord - Podmienia Xrecord
  • cd:DCT_SetXrecordVLA - Zmienia Xrecord


cd:DCT_AddDict

Dodaje słownik
(cd:DCT_AddDict Root Name)
Argumenty:
Root | [ENAME/nil] | ENAME = słownik "rodzic" nil = (namedobjdict) jako "rodzic"
Name | [STR] | nazwa słownika
Zwraca:
Entity-name nowo utworzonego słownika lub nil
Przykład:
Polecenie: (cd:DCT_AddDict (namedobjdict) "NAZWA")

<Entity name: 7ef03498>
Powiązane z:
cd:DCT_AddXrecord
cd:DCT_GetDict
cd:DCT_GetDictList
cd:DCT_GetExtDict
cd:DCT_GetExtDictVLA
cd:DCT_GetXrecord
cd:DCT_RemoveDict
cd:DCT_ReplaceXrecord
cd:DCT_SetXrecordVLA


cd:DCT_AddXrecord

Dodaje Xrecord
(cd:DCT_AddXrecord Root XName XData)
Argumenty:
Root | [ENAME/nil] | ENAME = słownik "rodzic" nil = (namedobjdict) jako "rodzic"
XName | [STR] | nazwa xrecord
XData | [LIST] | dane xrecord
Zwraca:
Entity-name nowo utworzonego xrecord lub nil
Przykład:
Polecenie: (cd:DCT_AddXrecord (cd:DCT_GetDict (namedobjdict) "NAZWA") "NAZWA-SUB1" '((1 . "ABC")))

<Entity name: 7ef034a0>
Powiązane z:
cd:DCT_AddDict
cd:DCT_GetDict
cd:DCT_GetDictList
cd:DCT_GetExtDict
cd:DCT_GetExtDictVLA
cd:DCT_GetXrecord
cd:DCT_RemoveDict
cd:DCT_ReplaceXrecord
cd:DCT_SetXrecordVLA


cd:DCT_GetDict

Pobiera słownik
(cd:DCT_GetDict Root Name)
Argumenty:
Root | [ENAME/nil] | ENAME = słownik "rodzic" nil = (namedobjdict) jako "rodzic"
Name | [STR] | nazwa słownika
Zwraca:
Entity-name słownika lub nil
Przykład:
Polecenie: (cd:DCT_GetDict (namedobjdict) "NAZWA")

<Entity name: 7ef03498>
Powiązane z:
cd:DCT_AddDict
cd:DCT_AddXrecord
cd:DCT_GetDictList
cd:DCT_GetExtDict
cd:DCT_GetExtDictVLA
cd:DCT_GetXrecord
cd:DCT_RemoveDict
cd:DCT_ReplaceXrecord
cd:DCT_SetXrecordVLA


cd:DCT_GetDictList

Pobiera listę słowników "rodzica"
(cd:DCT_GetDictList Root Code)
Argumenty:
Root | [ENAME/nil] | ENAME = słownik "rodzic" nil = (namedobjdict) jako "rodzic"
Code | [T/nil] | T = zwraca -> ((<slownik1> . <ENAME1>) ... ) nil = zwraca -> (<slownik1> <slownik2> ... )
Zwraca:
- lista par kropkowych: ((<slownik1> . <ENAME1>) ... )
- listę łańcuchów tekstowych ((<slownik1> . <slownik2>) ... )
- lub nil
Przykład:
Polecenie: (cd:DCT_GetDictList (cd:DCT_GetDict (namedobjdict) "NAZWA") T)

(("NAZWA-SUB1" . <Entity name: 7ffff6f4c30>) ("NAZWA-SUB2" . <Entity name: 7ffff6f4c40>))

Polecenie: (cd:DCT_GetDictList (cd:DCT_GetDict (namedobjdict) "NAZWA") nil)

(("NAZWA-SUB1") ("NAZWA-SUB2"))
Powiązane z:
cd:DCT_AddDict
cd:DCT_AddXrecord
cd:DCT_GetDict
cd:DCT_GetExtDict
cd:DCT_GetExtDictVLA
cd:DCT_GetXrecord
cd:DCT_RemoveDict
cd:DCT_ReplaceXrecord
cd:DCT_SetXrecordVLA


cd:DCT_GetExtDict

Pobiera/Tworzy ExtensionDictionary obiektu
(cd:DCT_GetExtDict Ename Flag)
Argumenty:
Ename | [ENAME] | nazwa entycji
Flag | [T/nil] | T = tworzy nil = pobiera jeśli istnieje
Zwraca:
Entity-name nowo utworzonego lub istniejącego słownika
Przykład:
Polecenie: (cd:DCT_GetExtDict (car (entsel)) T)

<Entity name: 7ef03498>
Powiązane z:
cd:DCT_AddDict
cd:DCT_AddXrecord
cd:DCT_GetDict
cd:DCT_GetDictList
cd:DCT_GetExtDictVLA
cd:DCT_GetXrecord
cd:DCT_RemoveDict
cd:DCT_ReplaceXrecord
cd:DCT_SetXrecordVLA


cd:DCT_GetExtDictVLA

Pobiera/Tworzy ExtensionDictionary obiektu
(cd:DCT_GetExtDictVLA Obj Flag)
Argumenty:
Obj | [ENAME/VLA-Object] | obiekt VLA lub entycja
Flag | [T/nil] | T = tworzy nil = pobiera jeśli istnieje
Zwraca:
Entity-name nowo utworzonego lub istniejącego słownika
Przykład:
Polecenie: (cd:DCT_GetExtDictVLA (namedobjdict) "NAZWA")

<Entity name: 7ef03498>
Powiązane z:
cd:DCT_AddDict
cd:DCT_AddXrecord
cd:DCT_GetDict
cd:DCT_GetDictList
cd:DCT_GetExtDict
cd:DCT_GetXrecord
cd:DCT_RemoveDict
cd:DCT_ReplaceXrecord
cd:DCT_SetXrecordVLA


cd:DCT_GetXrecord

Pobiera Xrecord
(cd:DCT_GetXrecord Ename)
Argumenty:
Ename [ENAME] nazwa entycji
Zwraca:
Listę par kropkowych xrecord
Przykład:
Polecenie: (cd:DCT_GetXrecord (cdar (cd:DCT_GetDictList (cd:DCT_GetDict (namedobjdict) "NAZWA") T)))

((1 . "ABC"))
Powiązane z:
cd:DCT_AddDict
cd:DCT_AddXrecord
cd:DCT_GetDict
cd:DCT_GetDictList
cd:DCT_GetExtDict
cd:DCT_GetExtDictVLA
cd:DCT_RemoveDict
cd:DCT_ReplaceXrecord
cd:DCT_SetXrecordVLA


cd:DCT_RemoveDict

Usuwa słownik
(cd:DCT_RemoveDict Root Name)
Argumenty:
Root | [ENAME/nil] | ENAME = słownik "rodzic" nil = (namedobjdict) jako "rodzic"
Name | [STR] | nazwa słownika
Zwraca:
Entity-name usuniętego słownika lub nil
Przykład:
Polecenie: (cd:DCT_RemoveDict (namedobjdict) "NAZWA")

<Entity name: 7ef03498>
Powiązane z:
cd:DCT_AddDict
cd:DCT_AddXrecord
cd:DCT_GetDict
cd:DCT_GetDictList
cd:DCT_GetExtDict
cd:DCT_GetExtDictVLA
cd:DCT_GetXrecord
cd:DCT_ReplaceXrecord
cd:DCT_SetXrecordVLA


cd:DCT_ReplaceXrecord

Podmienia Xrecord
(cd:DCT_ReplaceXrecord Ename Data)
Argumenty:
Ename | [ENAME/nil] | ENAME = słownik "rodzic" nil = (namedobjdict) jako "rodzic"
Data | [LIST] | lista par kropkowych
Zwraca:
Listę par kropkowych podmienionego xrecord
Przykład:
Polecenie: (cd:DCT_ReplaceXrecord (cdar (cd:DCT_GetDictList (cd:DCT_GetDict (namedobjdict) "NAZWA") T)) (list (cons 1 "NEW") (cons 341 (car (entsel)))))

((1 . "NEW") (341 . <Entity name: 7ffff6f4cd0>))
Powiązane z:
cd:DCT_AddDict
cd:DCT_AddXrecord
cd:DCT_GetDict
cd:DCT_GetDictList
cd:DCT_GetExtDict
cd:DCT_GetExtDictVLA
cd:DCT_GetXrecord
cd:DCT_RemoveDict
cd:DCT_SetXrecordVLA


cd:DCT_SetXrecordVLA

Zmienia Xrecord
(cd:DCT_SetXrecordVLA Ename Data)
Argumenty:
Ename | [ENAME/nil] | ENAME = słownik "rodzic" nil = (namedobjdict) jako "rodzic"
Data | [LIST] | lista par kropkowych
Zwraca:
Listę par kropkowych zmienionego xrecord
Przykład:
Polecenie: (cd:DCT_SetXrecordVLA (cdar (cd:DCT_GetDictList (cd:DCT_GetDict (namedobjdict) "NAZWA") T)) (list (cons 1 "NEW123") (cons 341 (car (entsel)))))

((1 . "NEW123") (341 . <Entity name: 7ffff6f4cd0;>))
Powiązane z:
cd:DCT_AddDict
cd:DCT_AddXrecord
cd:DCT_GetDict
cd:DCT_GetDictList
cd:DCT_GetExtDict
cd:DCT_GetExtDictVLA
cd:DCT_GetXrecord
cd:DCT_RemoveDict
cd:DCT_ReplaceXrecord


CADPL - DWG

DWG

Funkcje DWG:
  • cd:DWG_AddCustomProp - Dodaje właściwosci użytkownika
  • cd:DWG_GetCustomProp - Lista właściwosci użytkownika
  • cd:DWG_GetOpenDocs - Lista otwartych dokumentów
  • cd:DWG_GetSummaryInfo - Lista właściwosci dokumentu
  • cd:DWG_Layout2VLA - Zmiana nazwy arkusza na obiekt VLA
  • cd:DWG_LayoutsList - Lista arkuszy rysunku
  • cd:DWG_RemoveCustomProp - Usuwa właściwosci użytkownika
  • cd:DWG_SetSummaryInfo - Zmiana właściwosci dokumentu


cd:DWG_AddCustomProp

Dodaje właściwości użytkownika
(cd:DWG_AddCustomProp Doc Name Value Mode)
Argumenty:
Doc | [VLA-Object] | dokument
Name | [STR] | nazwa
Value | [STR] | wartość
Mode | [T/nil] | nil = nieaktualizuje istniejącej nazwy T = aktualizuje istniejącą nazwę
Zwraca:
nil
Przykład:
Polecenie: (cd:DWG_AddCustomProp (cd:ACX_ADoc) "One" "1" nil)

nil
Powiązane z:
cd:DWG_GetCustomProp
cd:DWG_RemoveCustomProp


cd:DWG_GetCustomProp

Lista właściwości użytkownika
(cd:DWG_GetCustomProp Doc)
Argumenty:
Doc [VLA-Object] dokument
Zwraca:
Listę par kropkowych: ((<właściwość> . <wartość>) ... ) lub nil
Przykład:
Polecenie: (cd:DWG_GetCustomProp (cd:ACX_ADoc))

(("One" . "1")) (("Two" . "2"))
Powiązane z:
cd:DWG_AddCustomProp
cd:DWG_RemoveCustomProp


cd:DWG_GetOpenDocs

Lista otwartych dokumentów
(cd:DWG_GetOpenDocs)
Argumenty:
Brak
Zwraca:
Listę par kropkowych: ((<dokument> . <VLA-Object>) ... )
Przykład:
Polecenie: (cd:DWG_GetOpenDocs)

(("Drawing1.dwg" . #<VLA-OBJECT IAcadDocument 0ba98794>))


cd:DWG_GetSummaryInfo

Lista właściwosci dokumentu
(cd:DWG_GetSummaryInfo Doc)
Argumenty:
Doc [VLA-Object] dokument
Zwraca:
Listę par kropkowych właściwości "Podsumowanie"
Przykład:
Polecenie: (cd:DWG_GetSummaryInfo (cd:ACX_ADoc))

(("Author" . "CADPL") ("Comments" . "") ("HyperLinkBase" . "www.cad.pl") ("Keywords" . "") ("LastSavedBy" . "Romek") ("RevisionNumber" . "") ("Subject" . "Open Source") ("Title" . "Projekt"))
Powiązane z:
cd:DWG_SetSummaryInfo


cd:DWG_Layout2VLA

Zmiana nazwy arkusza na obiekt VLA
(cd:DWG_Layout2VLA Layout)
Argumenty:
Layout [STR] nazwa arkusza
Zwraca:
VLA-Object aktywnego arkusza lub nil
Przykład:
Polecenie: (cd:DWG_Layout2VLA "Layout1")

#<VLA-OBJECT IAcadLayout 1489b65c>


cd:DWG_LayoutsList

Lista arkuszy rysunku
(cd:DWG_LayoutsList)
Argumenty:
Brak
Zwraca:
Listę: ((<arkusz> <numer arkusza> <VLA_Object>) ... )
Przykład:
Polecenie: (cd:DWG_LayoutsList)

(("Model" 0 #<VLA-OBJECT IAcadLayout 16fad654>) ("Layout1" 1 #<VLA-OBJECT IAcadLayout 16fad424>))


cd:DWG_RemoveCustomProp

Usuwa właściwosci użytkownika
(cd:DWG_RemoveCustomProp Doc Mode)
Argumenty:
Doc | [VLA-Object] | dokument
Mode | [LIST/T] | LIST = lista właściwości do usunięcia T = usuwa wszystkie właściwości
Zwraca:
nil
Przykład:
Polecenie: (cd:DWG_RemoveCustomProp (cd:ACX_ADoc) (list "One" "Two"))

nil
Powiązane z:
cd:DWG_AddCustomProp
cd:DWG_GetCustomProp


cd:DWG_SetSummaryInfo

Zmiana właściwości dokumentu
(cd:DWG_SetSummaryInfo Doc Data)
Argumenty:
Doc | [VLA-Object] | dokument
Data | [LIST/T] | LIST = lista par kropkowych T = usuwa wszystkie
Zwraca:
nil
Przykład:
Polecenie: (cd:DWG_SetSummaryInfo (cd:ACX_ADoc) '(("Author" . "CADPL")("HyperLinkBase" . "www.cad.pl")("Subject" . "Open Source")("Title" . "Projekt")))

nil
Powiązane z:
cd:DWG_GetSummaryInfo


CADPL - DXF

DXF

Funkcje DXF:
  • cd:DXF_Massoc - Zwraca wartość danego klucza z listy asocjacyjnej
  • cd:DXF_RemoveDXF - Usuwa kody z listy DXF


cd:DXF_Massoc

Zwraca wartość danego klucza z listy asocjacyjnej
(cd:DXF_Massoc Key Data)
Argumenty:
Key | [INT] | klucz
Data | [LIST] | lista par kropkowych
Zwraca:
Wartość danego klucza
Przykład:
Polecenie: (cd:DXF_Massoc 10 (entget (car (entsel)))))

((2816.0 1047.69) (2816.0 1303.62) (2862.64 1350.26) (3023.59 1350.26))


cd:DXF_RemoveDXF

Usuwa kody z listy DXF
(cd:DXF_RemoveDXF Data Lst)
Argumenty:
Data | [LIST] | lista wejściowa
Lst | [LIST] | lista kodów do usunięcia
Zwraca:
Listę asocjacyjną bez kodów Lst
Przykład:
Polecenie: (cd:DXF_RemoveDXF (entget (entlast)) (list -1 3 5 102 330 360 440))

((0 . "LWPOLYLINE") (100 . "AcDbEntity") (67 . 0) (410 . "Model") (8 . "0") (100 . "AcDbPolyline") (90 . 4) (70 . 1) (43 . 0.0) (38 . 0.0) (39 . 0.0) (10 17.1488 8.38281) (40 . 0.0) (41 . 0.0) (42 . 0.0) (91 . 0) (10 19.0632 8.38281) (40 . 0.0) (41 . 0.0) (42 . 0.0) (91 . 0) (10 19.0632 6.85135) (40 . 0.0) (41 . 0.0) (42 . 0.0) (91 . 0) (10 17.1488 6.85135) (40 . 0.0) (41 . 0.0) (42 . 0.0) (91 . 0) (210 0.0 0.0 1.0))


CADPL - ENT

ENT

Funkcje ENT:
  • cd:ENT_CheckTableObj - Sprawdza poprawność nazwanego obiektu
  • cd:ENT_MakeArc - Tworzy obiekt typu ARC
  • cd:ENT_MakeBlockEnd - Tworzy koniec definicji bloku
  • cd:ENT_MakeBlockHead - Tworzy początek definicji bloku
  • cd:ENT_MakeCircle - Tworzy obiekt typu CIRCLE
  • cd:ENT_MakeEllipse - Tworzy obiekt typu ELLIPSE
  • cd:ENT_MakeLayer - Tworzy nową warstwę
  • cd:ENT_MakeLine - Tworzy obiekt typu LINE
  • cd:ENT_MakeLWPolyline - Tworzy obiekt typu LWPOLYLINE
  • cd:ENT_MakeTable - Tworzy obiekt typu ACAD_TABLE
  • cd:ENT_MakeText - Tworzy obiekt typu TEXT
  • cd:ENT_MakeTextStyle - Tworzy nowy styl tekstu
  • cd:ENT_MakeXline - Tworzy obiekt typu XLINE
  • cd:ENT_SetBasicDXF - Zmiana podstawowych cech obiektu
  • cd:ENT_SetDXF - Zmiana danych DXF obiektu


cd:ENT_CheckTableObj

Sprawdza poprawność nazwanego obiektu
(cd:ENT_CheckTableObj Table Name)
Argumenty:
Table | [STR] | nazwa obiektu
Name | [STR] | nazwa do sprawdzenia
Zwraca:
0 = obiekt nie istnieje
-1 = zła nazwa
1 = obiekt istnieje
Przykład:
Polecenie: (cd:ENT_CheckTableObj "LAYER" "0")

1

Polecenie: (cd:ENT_CheckTableObj "BLOCK" "nazwa")

0


cd:ENT_MakeArc

Tworzy obiekt typu ARC
(cd:ENT_MakeArc Layout Pc Radius As Ae ActUcs)
Argumenty:
Layout | [STR] | nazwa arkusza
Pc | [LIST] | środek łuku
Radius | [REAL] | promień
As | [LIST] | kąt początkowy w radianach
Ae | [LIST] | kąt końcowy w radianach
ActUcs | [T/nil] | dopasuj do aktywnego ucs: nil = nie T = tak
Zwraca:
Entity-name nowo utworzonego łuku
Przykład:
Polecenie: (cd:ENT_MakeArc "Model" '(1 5 0) 5 0 pi T)

<Entity name: 7ef09880>
Powiązane z:
cd:ACX_AddArc


cd:ENT_MakeBlockEnd

Tworzy koniec definicji bloku
(cd:ENT_MakeBlockEnd)
Argumenty:
Brak
Zwraca:
Zwraca Name definicji bloku lub nil
Przykład:
Polecenie: (cd:ENT_MakeBlockEnd)

"NOWY"
Powiązane z:
cd:ENT_MakeBlockHead


cd:ENT_MakeBlockHead

Tworzy początek definicji bloku
(cd:ENT_MakeBlockHead Name Pb Flag)
Argumenty:
Name | [STR] | nazwa bloku
Pb | [LIST] | punkt bazowy bloku
Flag | [INT] | typ bloku (bit-kody, można łaczyć): 0 = standardowy blok 1 = blok anonimowy 2 = blok z definicjami atrybutów (nie-stałymi)
Zwraca:
<Entity name: 0>
Przykład:
Polecenie: (cd:ENT_MakeBlockHead "NOWY" (list 0 0 0) 0)

<Entity name: 0>

Polecenie: (cd:ENT_MakeBlockHead "*U" (list 0 0 0) 1)

<Entity name: 0>
Powiązane z:
cd:ENT_MakeBlockEnd


cd:ENT_MakeCircle

Tworzy obiekt typu CIRCLE
(cd:ENT_MakeCircle Layout Pc Radius ActUcs)
Argumenty:
Layout | [STR] | nazwa arkusza
Pc | [LIST] | środek okręgu
Radius | [REAL] | promień
ActUcs | [T/nil] | dopasuj do aktywnego ucs: nil = nie T = tak
Zwraca:
Entity-name nowo utworzonego okręgu
Przykład:
Polecenie: (cd:ENT_MakeCircle "Model" '(1 5 0) 5 T)

<Entity name: 7ef09398>
Powiązane z:
cd:ACX_AddCircle


cd:ENT_MakeEllipse

Tworzy obiekt typu ELLIPSE
(cd:ENT_MakeEllipse Layout Pc Width Height RotAng ActUcs)
Argumenty:
Layout | [STR] | nazwa arkusza
Pc | [LIST] | środek elipsy
Width | [REAL] | szerokość
Height | [REAL] | wysokość
RotAng | [REAL] | kąt obrotu
ActUcs | [T/nil] | dopasuj do aktywnego ucs: nil = nie T = tak
Zwraca:
Entity-name nowo utworzonej elipsy
Przykład:
Polecenie: (cd:ENT_MakeEllipse "Model" '(1 5 0) 10.0 5.0 (* pi 0.25) T)

<Entity name: 7eff7b38>


cd:ENT_MakeLayer

Tworzy nową warstwę
(cd:ENT_MakeLayer Name)
Argumenty:
Name [STR] nazwa warstwy
Zwraca:
Entity-name utworzonej warstwy lub nil
Przykład:
Polecenie: (cd:ENT_MakeLayer "ABC")

<Entity name: 7ef044d0>>
Powiązane z:
cd:ACX_AddLayer


cd:ENT_MakeLine

Tworzy obiekt typu LINE
(cd:ENT_MakeLine Layout Ps Pe ActUcs)
Argumenty:
Layout | [STR] | nazwa arkusza
Ps | [LIST] | punkt początkowy
Pe | [LIST] | punkt końcowy
ActUcs | [T/nil] | dopasuj do aktywnego ucs: nil = nie T = tak
Zwraca:
Entity-name utworzonej linii
Przykład:
Polecenie: (cd:ENT_MakeLine "Model" '(20 10 0) '(100 50 0))

<Entity name: 7ef044d8>
Powiązane z:
cd:ACX_AddLine


cd:ENT_MakeLWPolyline

Tworzy obiekt typu LWPOLYLINE
(cd:ENT_MakeLWPolyline Layout Pts Closed)
Argumenty:
Layout | [STR] | nazwa arkusza
Pts | [LIST] | lista wierzchołków polilinii
Closed | [T/nil] | nil = otwarta T = zamknięta
Zwraca:
Entity-name nowo utworzonej polilinii
Przykład:
Polecenie: (cd:ENT_MakeLWPolyline "Model" (list '(5 5) '(15 5) '(15 10) '(10 10)) nil)

<Entity name: 7eea7fb8>
Powiązane z:
cd:ACX_AddLWPolyline


cd:ENT_MakeTable

Tworzy obiekt typu ACAD_TABLE
(cd:ENT_MakeTable Pb Rows Cols RowH ColH)
Argumenty:
Pb | [LIST] | punkt bazowy tabeli
Rows | [INT] | liczba wierszy
Cols | [INT] | liczba kolumn
RowH | [INT] | wysokość wierszy
ColH | [INT] | szerokość kolumn
Zwraca:
Entity-name utworzonej tabeli
Przykład:
Polecenie: (cd:ENT_MakeTable (getpoint) 5 5 10 30)

<Entity name: 7ef034e0>
Powiązane z:
cd:ACX_AddTable


cd:ENT_MakeText

Tworzy obiekt typu TEXT
(cd:ENT_MakeText Layout Str Pb Height Rot)
Argumenty:
Layout | [STR] | nazwa arkusza
Str | [STR] | łańcuch tekstowy
Pb | [LIST] | punkt bazowy
Height | [REAL] | wysokość
Rot | [REAL] | kąt obrotu w radianach
Zwraca:
Entity-name utworzonego tekstu
Przykład:
Polecenie: (cd:ENT_MakeText "Model" "NEW_TEXT" (getpoint) 1.5 (/ pi 4)))

<Entity name: 7eefd000>
Powiązane z:
cd:ACX_AddText


cd:ENT_MakeTextStyle

Tworzy nowy styl tekstu
(cd:ENT_MakeTextStyle Name)
Argumenty:
Name [STR] nazwa stylu tekstu
Zwraca:
Entity-name utworzonego stylu tekstu lub nil
Przykład:
Polecenie: (cd:ENT_MakeTextStyle "ABC")

<Entity name: 7ef044e0>
Powiązane z:
cd:ACX_AddTextStyle


cd:ENT_MakeXline

Tworzy obiekt typu XLINE
(cd:ENT_MakeXline Layout Ps Pe)
Argumenty:
Layout | [STR] | nazwa arkusza
Ps | [LIST] | punkt początkowy
Pe | [LIST/REAL] | punkt końcowy lub kąt w radianach
Zwraca:
Entity-name nowo utworzonej linii konstrukcyjnej
Przykład:
Polecenie: (cd:ENT_MakeXline "Model" (getpoint) (/ pi 4))

<Entity name: 7ef04640>
Powiązane z:
cd:ACX_AddXLine


cd:ENT_SetBasicDXF

Zmiana podstawowych cech obiektu
(cd:ENT_SetBasicDXF Ename Layer Color LType LScale LWeight)
Argumenty:
Ename | [ENAME] | nazwa elementu
Layer | [STR] | nazwa warstwy
Color | [INT] | kolor warstwy
LType | [STR] | typ linii
LScale | [REAL] | skala linii
LWeight | [INT] | szerokość linii
Zwraca:
Entity-name modyfikowanego obiektu lub nil
Przykład:
Polecenie: (cd:ENT_SetBasicDXF (entlast) "NOWA" 21 "CONTINUOS" 1.5 13)

nil


cd:ENT_SetDXF

Zmiana danych DXF obiektu
(cd:ENT_SetDXF Ename Code Val)
Argumenty:
Ename | [ENAME] | nazwa elementu
Code | [INT] | kod pary DXF
Val | [LIST/INT/REAL/STR/ENAME] | wartość
Zwraca:
Listę asocjacyjną modyfikowanego obiektu lub nil
Przykład:
Polecenie: (cd:ENT_SetDXF (entlast) 70 129)

((-1 . <Entity name: 7ef04518>) (0 . "LWPOLYLINE") (330 . <Entity name: 7ef7fcf8>) (5 . "193") (100 . "AcDbEntity") (67 . 0) (410 . "Model") (8 . "0") (100 . "AcDbPolyline") (90 . 2) (70 . 129) (43 . 0.0) (38 . 0.0) (39 . 0.0) (10 18.1741 10.1904) (40 . 0.0) (41 . 0.0) (42 . 0.0) (91 . 0) (10 19.7039 11.1797) (40 . 0.0) (41 . 0.0) (42 . 0.0) (91 . 0) (210 0.0 0.0 1.0))


CADPL - LST

LST

Funkcje LST:
  • cd:LST_InsertItem - Wstawia nowy element na liste
  • cd:LST_ItemPosition - Lista wystąpień elementu na liście
  • cd:LST_MoveItemDown - Przesuwa element o jedną pozycję w dół
  • cd:LST_MoveItemToBottom - Przesuwa element na ostatnią pozycję
  • cd:LST_MoveItemToTop - Przesuwa element na pozycję 0
  • cd:LST_MoveItemUp - Przesuwa element o jedną pozycję w górę
  • cd:LST_RemoveItem - Usuwa element z listy
  • cd:LST_ReplaceItem - Zastępuje element na liście
  • cd:LST_ReverseItems - Zastępuje element na liście


cd:LST_InsertItem

Wstawia nowy element na liste
(cd:LST_InsertItem Pos Lst New)
Argumenty:
Pos | [INT] | pozycja elementu
Lst | [LIST] | lista wejściowa
New | [LIST/INT/REAL/STR/ENAME] | nowy element
Zwraca:
Listę z nowym elementem New
Przykład:
Polecenie: (cd:LST_InsertItem 3 (list 0 1 2 4 5) 3)

(0 1 2 3 4 5)


cd:LST_ItemPosition

Lista wystąpień elementu na liście
(cd:LST_ItemPosition Item Lst)
Argumenty:
Item | [INT] | pozycja elementu
Lst | [LIST] | lista wejściowa
Zwraca:
Lista wystąpień/pozycji elementu Item na liście
Przykład:
Polecenie: (cd:LST_ItemPosition 1 (list 0 "a" 1 "b" 3 1))

(2 5)


cd:LST_MoveItemDown

Przesuwa element o jedną pozycję w dół
(cd:LST_MoveItemDown Pos Lst)
Argumenty:
Pos | [INT] | pozycja elementu
Lst | [LIST] | lista wejściowa
Zwraca:
Listę z przesuniętym elementem
Przykład:
Polecenie: (cd:LST_MoveItemDown 3 (list 0 1 2 3 4 5))

(0 1 2 4 3 5)
Powiązane z:
cd:LST_MoveItemUp


cd:LST_MoveItemToBottom

Przesuwa element na ostatnią pozycję
(cd:LST_MoveItemToBottom Pos Lst)
Argumenty:
Pos | [INT] | pozycja elementu
Lst | [LIST] | lista wejściowa
Zwraca:
Listę z przesuniętym elementem
Przykład:
Polecenie: (cd:LST_MoveItemToBottom 3 (list 0 1 2 3 4 5))

(0 1 2 4 5 3)
Powiązane z:
cd:LST_MoveItemToTop


cd:LST_MoveItemToTop

Przesuwa element na pozycję 0
(cd:LST_MoveItemToTop Pos Lst)
Argumenty:
Pos | [INT] | pozycja elementu
Lst | [LIST] | lista wejściowa
Zwraca:
Listę z przesuniętym elementem
Przykład:
Polecenie: (cd:LST_MoveItemToTop 3 (list 0 1 2 3 4 5))

(3 0 1 2 4 5)
Powiązane z:
cd:LST_MoveItemToBottom


cd:LST_MoveItemUp

Przesuwa element o jedną pozycję w górę
(cd:LST_MoveItemUp Pos Lst)
Argumenty:
Pos | [INT] | pozycja elementu
Lst | [LIST] | lista wejściowa
Zwraca:
Listę z przesuniętym elementem
Przykład:
Polecenie: (cd:LST_MoveItemUp 3 (list 0 1 2 3 4 5))

(0 1 3 2 4 5)
Powiązane z:
cd:LST_MoveItemDown


cd:LST_RemoveItem

Usuwa element z listy
(cd:LST_RemoveItem Pos Lst)
Argumenty:
Pos | [INT] | pozycja elementu
Lst | [LIST] | lista wejściowa
Zwraca:
Listę bez elementu z pozycji Pos
Przykład:
Polecenie: (cd:LST_RemoveItem 1 (list 0 "a" "b" 3))

(0 "b" 3)


cd:LST_ReplaceItem

Zastępuje element na liście
(cd:LST_ReplaceItem Pos Lst New)
Argumenty:
Pos | [INT] | pozycja elementu
Lst | [LIST] | lista wejściowa
New | [LIST/INT/REAL/STR/ENAME] | nowy element
Zwraca:
Listę z nowym elementem New
Przykład:
Polecenie: (cd:LST_ReplaceItem 2 (list 0 "a" "b" 3) 2)

(0 "a" 2 3)


cd:LST_ReverseItems

Zamienia elementy miejscami
(cd:LST_ReverseItems Pos1 Pos2 Lst)
Argumenty:
Pos1 | [INT] | pozycja 1-go elementu
Pos2 | [INT] | pozycja 2-go elementu
Lst | [LIST] | lista wejściowa
Zwraca:
Listę z zamienionymi elementami
Przykład:
Polecenie: (cd:LST_ReverseItems 0 5 (list 0 1 2 3 4 5))

(5 1 2 3 4 0)


CADPL - SSX

SSX

Funkcje SSX:
  • cd:SSX_Convert - Zmienia zbiór wskazań na listę obiektów
  • cd:SSX_DynBlockFilter - Filtr bloków dynamicznych


cd:SSX_Convert

Zmienia PICKSET na listę obiektów
(cd:SSX_Convert Ss Mode)
Argumenty:
Ss | [PICKSET] | zbiór wskazań
Mode | [INT] | typ zwracanych obiektów: 0 = ENAME 1 = VLA-OBJECT 2 = SAFEARRAY
Zwraca:
Listę obiektów odpowiedniego typu
Przykład:
Polecenie: (cd:SSX_Convert (ssget) 1)

(#<VLA-OBJECT IAcadLWPolyline 1344f724> #<VLA-OBJECT IAcadLWPolyline 1344f0c4>)


cd:SSX_DynBlockFilter

Filtr bloków dynamicznych
(cd:SSX_DynBlockFilter Mode Name)
Argumenty:
Mode | [T/nil] | tryb wyboru bloków: nil - wskazanie użytkownika T - wszystkie z rysunku
Name | [STR] | nazwa bloku
Zwraca:
Zbiór wskazań lub nil
Przykład:
Polecenie: (cd:SSX_DynBlockFilter T "ELEVATION TAG")

<Selection set: 278>


cd:CADPL - STR

STR

Funkcje STR:
  • cd:STR_CountChar - Liczba wystąpień znaku
  • cd:STR_FillChar - Uzupełnia łańcuch tekstowy znakami
  • cd:STR_Parse - Dzieli łańcuch separatorem
  • cd:STR_ReParse - Łączy listę łańcuchów w łańcuch z separatorem
  • cd:STR_TableNameAuto - Tworzy automatyczną nazwę


cd:STR_CountChar

Liczba wystąpień znaku
(cd:STR_CountChar Str Char)
Argumenty:
Str | [STR] | łańcuch tekstowy
Char | [STR] | znak
Zwraca:
Liczbę całkowitą wystąpień znaku Char
Przykład:
Polecenie: (cd:STR_CountChar "\"123\" \"416\" \"719\" \"A1c\"" "\"")

8


cd:STR_FillChar

Uzupełnia łańcuch tekstowy znakami
(cd:STR_FillChar Str Char Pos Dir)
Argumenty:
Str | [STR] | łańcuch tekstowy
Char | [STR] | znak
Pos | [INT] | całkowita liczba znaków
Dir | [T/nil] | kierunek uzupełniania: nil = w lewo T = w prawo
Zwraca:
Łańcuch tekstowy
Przykład:
Polecenie: (cd:STR_FillChar "12" "0" 5 nil)

"00012"

Polecenie: (cd:STR_FillChar "12" "0" 5 T)

"12000"


cd:STR_Parse

Dzieli łańcuch separatorem
(cd:STR_Parse Str Sep Rbl)
Argumenty:
Str | [STR] | łańcuch tekstowy
Sep | [STR] | znak rozdzielający
Rbl | [T/nil] | nil = nie usuwa pustych tekstów T = usuwa puste teksty
Zwraca:
Listę łańcuchów tekstowych
Przykład:
Polecenie: (cd:STR_Parse ";;1;2;3;;;9;" ";" nil)

("" "" "1" "2" "3" "" "" "9" "")

Polecenie:(cd:STR_Parse ";;1;2;3;;;9;" ";" T)

("1" "2" "3" "9")
Powiązane z:
cd:STR_ReParse


cd:STR_ReParse

Łączy listę łańcuchów w łańcuch z separatorem
(cd:STR_ReParse Lst Sep)
Argumenty:
Lst | [LIST] | lista łańcuchów
Sep | [STR] | separator
Zwraca:
Łańcuch tekstowy z separatorem
Przykład:
Polecenie: (cd:STR_ReParse '("OLE2FRAME" "IMAGE" "HATCH") ",")

"OLE2FRAME,IMAGE,HATCH"
Powiązane z:
cd:STR_Parse


cd:STR_TableNameAuto

Tworzy automatyczną nazwę
(cd:STR_TableNameAuto Tbl Pref Suff Char Len)
Argumenty:
Tbl | [STR] | tablica symboli
Pref | [STR] | prefiks
Suff | [STR] | sufiks
Char | [STR] | znak uzupełniający
Len | [INT] | całkowita liczba znaków
Zwraca:
Łańcuch tekstowy
Przykład:
Polecenie: (cd:STR_TableNameAuto "BLOCK" "Front_" "_Tyl" "." 3)

"Front_..1_Tyl"

Polecenie: (cd:STR_TableNameAuto "LAYER" "Pre_" nil "0" 5)

"Pre_00001"


cd:CADPL - SYS

SYS

Funkcje SYS:
  • cd:SYS_AcadInfo - AcadInfo np. ("AutoCAD" 18.0 64 "PL")
  • cd:SYS_CheckError - Sprawdza poprawność działania funkcji
  • cd:SYS_CollList - Zwraca listę obiektów wybranego typu
  • cd:SYS_FilesLoader - Wczytuje pliki lsp,fas,vlx
  • cd:SYS_FontPaths - Zwraca listę ścieżek do czcionek
  • cd:SYS_GetDateTime - Zwraca datę/czas systemową(y)
  • cd:SYS_GetFonts - Zwraca listę czcionek systemowych
  • cd:SYS_GetSymbols - Zwraca listę symboli LISP-a
  • cd:SYS_Msgbox - Standardowe okno komunikatu
  • cd:SYS_ReadFile - Czyta plik tekstowy
  • cd:SYS_RW - Odczyt/Zapis danych w rejestrze
  • cd:SYS_UndoBegin - Początek grupy operacji
  • cd:SYS_UndoEnd - Koniec grupy operacji
  • cd:SYS_WriteFile - Zapisuje plik tekstowy


cd:SYS_AcadInfo

AcadInfo
(cd:SYS_AcadInfo)
Argumenty:
Brak
Zwraca:
Lista
Przykład:
Polecenie: (cd:SYS_AcadInfo)

("AutoCAD" 18.0 64 "PL")


cd:SYS_CheckError

Sprawdza poprawność działania funkcji
(cd:SYS_CheckError Lst)
Argumenty:
Lst [LIST] sprawdzana funkcja z argumentami
Zwraca:
Wynik działania sprawdzanej funkcji lub nil w przypadku wystąpienia błędu
Przykład:
Polecenie: (cd:SYS_CheckError (list cd:CAL_BitList 199))

(1 2 4 64 128)

Polecenie: (cd:SYS_CheckError (list cd:CAL_BitList "199"))

nil


cd:SYS_CollList

Zwraca listę obiektów wybranego typu
(cd:SYS_CollList Coll Bit)
Argumenty:
Coll | [STR] | typ obiektu
Bit | [INT] | liczba całkowita (suma bitów): 0 = bezwzględnie wszystkie 1 = bez Model/Papier dla BLOCK i "" dla STYLE 2 = bez anonimowych (BLOCK, GROUP, TABLE, VPORT) 4 = bez zależnych od odnośników zewnętrznych 8 = bez odnośników zewnętrznych 16 = wszystkie anonimowe 32 = tylko odnośniki zewnętrzne
Zwraca:
Listę obiektów
Przykład:
Polecenie: (cd:SYS_CollList "BLOCK" (+ 1 2 4))

("cbb2" "cbe2" "cbu2" "GrassFO_BR" "pullelev" "_ARCHTICK" "_CLOSEDBLANK")


cd:SYS_FilesLoader

Wczytuje pliki lsp,fas,vlx
(cd:SYS_FilesLoader Lst)
Argumenty:
Lst [LIST] lista plików
Zwraca:
Lista par kropkowych niewczytanych plików: ((<nazwa pliku> . <rodzaj błąd>) ... ) lub nil
Przykład:
Polecenie: (cd:SYS_FilesLoader (list "CADPL-Pack-v1.lsp" "Brak.fas" "Nawias.lsp"))

(("Brak.fas" . "LOAD failed: \"Brak.fas\"") ("Nawias.lsp" . "extra right paren on input"))


cd:SYS_FontPaths

Zwraca listę ścieżek do czcionek
(cd:SYS_FontPaths)
Argumenty:
Brak
Zwraca:
Lista
Przykład:
Polecenie: (cd:SYS_FontPaths)

("C:\\WINDOWS\\fonts" "C:\\program files\\autodesk\\autocad 2012 - english\\fonts")


cd:SYS_GetDateTime

Zwraca datę/czas systemową(y)
(cd:SYS_GetDateTime Format)
Argumenty:
Format [STR]
Data: |  |
D | --> | 5
DD | --> | 05
DDD | --> | Sob
DDDD | --> | Sobota
M | --> | 9
MO | --> | 09
MON | --> | Wrz
MONTH | --> | Wrzesień
YY | --> | 89
YYYY | --> | 1989
Czas: |  |
H | --> | 4
HH | --> | 04
MM | --> | 53
SS | --> | 17
MSEC | --> | 506
AM/PM | --> | AM or PM
am/pm | --> | am or pm
A/P | --> | A or P
a/p | --> | a or p
Zwraca:
Zwraca datę/czas systemową(y) w postaci łańcucha tekstowego
Przykład:
Polecenie: (cd:SYS_GetDateTime "DDD\",\" DD MON YYYY - H:MMam/pm")

"Czw, 29 Mar 2012 - 11:55pm"


cd:SYS_GetFonts

Zwraca listę czcionek systemowych
(cd:SYS_GetFonts)
Argumenty:
Brak
Zwraca:
Lista par kropkowych czcionek: ((<nazwa czcionki> . <nazwa pliku>) ... )
Przykład:
Polecenie: (cd:SYS_GetFonts)

(("Bookman Old Style Italic" . "BOOKOSI.TTF") ("Bookman Old Style Bold Italic" . "BOOKOSBI.TTF") ... )


cd:SYS_GetSymbols

Zwraca listę symboli AutoLISP-a
(cd:SYS_GetSymbols Str)
Argumenty:
Str [STR] szukany ciąg znaków
Zwraca:
Lista par kropkowych: ((<nazwa funkcji> . <procedura>) ... )
Przykład:
Polecenie: (cd:SYS_GetSymbols "cd:")

(("CD:ACX_ADDLAYER" . #<SUBR @1ce43cf8 CD:ACX_ADDLAYER>) ("CD:ACX_ADDLINE" . #<SUBR @1cedc050 CD:ACX_ADDLINE>) ... )


cd:SYS_MsgBox

Standardowe okno komunikatu
(cd:SYS_MsgBox Msg Title Btn Icon)
Argumenty:
Msg | [STR] | komunikat do wyświetlenia
Title | [STR] | tytuł okna
Btn | [0/1/2/3/4/5/6] | przyciski: 0 = OK 1 = OK i Anuluj 2 = Przerwij, Ponów próbe i Ignoruj 3 = Tak, Nie i Anuluj 4 = Tak i Nie 5 = Ponów próbe i Anuluj 6 = Anuluj, Ponów próbe Kontynuuj
Icon | [16/32/48/64] | wyświetlany symbol: 16 = "Stop" [X] 32 = "Pytanie" [?] 48 = "Uwaga" [!] 64 = "Informacja" [i]
Zwraca:
1 = OK
2 = Anuluj
3 = Przerwij
4 = Ponów próbę; Btn=2 lub Btn=5
5 = Ignoruj
6 = Tak
7 = Nie
10 = Ponów próbę; Btn=6
11 = Kontynuuj
Przykład:
Polecenie: (cd:SYS_MsgBox "Komunikat\nw 2 liniach" "Uwaga" 6 64)
Sample of SYS_MsgBox


cd:SYS_ReadFile

Czyta plik tekstowy
(cd:SYS_ReadFile Line File)
Argumenty:
Line | [INT/nil] | numer linii pliku: INT = numer linii pliku nil = cały plik
File | [STR] | nazwa pliku (krótka lub ze ścieżką)
Zwraca:
nil = gdy Line=INT większe niż ilość linii w pliku lub plik jest pusty
0 = brak dostępu do pliku
-1 = nie znaleziono pliku
STR = gdy Line=INT
LIST = gdy Line=nil
Przykład:
Polecenie: (cd:SYS_ReadFile nil "data.ini")

-1

Polecenie: (cd:SYS_ReadFile 10 "acad.lin")

"*BORDER,Border __ __ . __ __ . __ __ . __ __ . __ __ ."


cd:SYS_RW

Odczyt/Zapis danych w rejestrze
(cd:SYS_RW Key Name Data)
Argumenty:
Key | [STR] | klucz rejestru
Name | [STR] | wartość wpisu w rejestrze
Data | [STR/nil] | nil = odczyt danych STR = dane do zapisu
Zwraca:
Zwraca dane odczytane/zapisane w rejestrze lub nil
Przykład:
Polecenie: (cd:SYS_RW "CADPL\\Tools\\MakeBlock" "Version" "1.0")

"1.00"


cd:SYS_UndoBegin

Początek grupy operacji
(cd:SYS_UndoBegin)
Argumenty:
Brak
Zwraca:
nil
Przykład:
Polecenie: (cd:SYS_UndoBegin)

nil
Powiązane z:
cd:SYS_UndoEnd


cd:SYS_UndoEnd

Koniec grupy operacji
(cd:SYS_UndoEnd)
Argumenty:
Brak
Zwraca:
nil
Przykład:
Polecenie: (cd:SYS_UndoEnd)

nil
Powiązane z:
cd:SYS_UndoBegin


cd:SYS_WriteFile

Zapisuje plik tekstowy
(cd:SYS_WriteFile Name Lst Mode)
Argumenty:
Name | [STR] | nazwa pliku ze ścieżką
Lst | [LIST] | lista do zapisu
Mode | [T/nil] | tryb zapisu: nil - nadpisywanie pliku T - dopisywanie do pliku
Zwraca:
nil = zapis zakończony niepowodzeniem
T = zapis zakończony powodzeniem
Przykład:
Polecenie: (cd:SYS_WriteFile "d:\\Plik.txt" (list "linia 1" "linia 2" "linia 3") nil)

T


cd:CADPL - USR

USR

Funkcje USR:
  • cd:USR_EntSelObj - Wybiera zadane obiekty
  • cd:USR_GetCorner - Pobiera drugi narożnik prostokąta
  • cd:USR_GetKeyWord - Pobiera słowo kluczowe od użytkownika
  • cd:USR_GetPoint - Pobiera punkt od użytkownika


cd:USR_EntSelObj

Wybiera zadane obiekty
(cd:USR_EntSelObj Msg Obj Init Lock Enter)
Argumenty:
Msg | [LIST] | lista komunikatów
Obj | [LIST/nil] | LIST = lista zadanych obiektów nil = wybiera dowolne obiekty
Init | [STR/nil] | STR = słowa kluczowe nil = bez słów kluczowych
Lock | [T/nil] | pomija obiekty na zamkniętej warstwie: nil = tak T = nil
Enter | [T/nil] | zakończ prawy klik/spacja/enter: nil = nie T = tak
Zwraca:
Entity-name wskazanego obiektu lub słowo kluczowe
Przykład:
Polecenie: (cd:USR_EntSelObj (list "\nWybierz blok [Opcje/Wyjdź]: " "Należy wskazać blok " "Nic nie wybrano " "To nie blok " "Obiekt na zamkniętej warstwie ") (list "INSERT") "Opcje Wyjdź" T nil)

Wybierz blok [Opcje/Wyjdź]: o

"Opcje"

Polecenie: (cd:USR_EntSelObj (list "\nWybierz dowolny obiekt: " "" "Nic nie wybrano " "" "Obiekt na zamknietej warstwie ") nil nil nil T)

Wybierz dowolny obiekt: <Entity name: 7efd76d0>


cd:USR_GetCorner

Pobiera drugi narożnik prostokąta
(cd:USR_GetCorner Msg Bit Pt)
Argumenty:
Pt | [LIST] | punkt bazowy
Msg | [STR] | komunikat do wyświetlenia
Mode | [T/nil] | typ zwracanych danych nil = drugi narożnik T = lista współrzędnych w kolejności: DL DP GP GL
Zwraca:
Punkt, lista lub nil
Przykład:
(cd:USR_GetCorner (getpoint) "\nWskaz drugi naroznik: " T)

Wskaz drugi naroznik: ((-10.4331 1.83507) (-7.22132 1.83507) (-7.22132 4.78538) (-10.4331 4.78538))


cd:USR_GetKeyWord

Pobiera słowo kluczowe od użytkownika
(cd:USR_GetKeyWord Msg Keys Def)
Argumenty:
Msg | [STR] | tekst zapytania
Keys | [LIST] | lista możliwych słów kluczowych
Def | [STR] | domyślne słowo kluczowe
Zwraca:
Słowo kluczowe lub nil
Przykład:
Polecenie: (cd:USR_GetKeyWord "\nUtwórz blok" '("Anonimowy" "Nazwa") "Nazwa")

Utwórz blok [Anonimowy/Nazwa] <Nazwa>: a

"Anonimowy"


cd:USR_GetPoint

Pobiera punkt od użytkownika
(cd:USR_GetPoint Msg Bit Pt)
Argumenty:
Msg | [STR] | komunikat do wyświetlenia
Bit | [INT/nil] | bit sterujacy (patrz initget)
Pt | [LIST/nil] | punkt bazowy
Zwraca:
Punkt lub nil
Przykład:
Polecenie: (cd:USR_GetPoint "\nWskaż punkt: " 1 nil)

Wskaż punkt: (2979.03 1893.79 0.0)

Polecenie: (cd:USR_GetPoint "\nWskaż drugi punkt: " 32 '(5 10 0))

Wskaż drugi punkt: (3012.12 1920.47 0.0)


CADPL - XDT

XDT

Funkcje XDT:
  • cd:XDT_GetXData - Czyta dane dodatkowe XDATA
  • cd:XDT_PutXData - Dodaje dane dodatkowe XDATA
  • cd:XDT_RemoveXData - Usuwa dane dodatkowe XDATA


cd:XDT_GetXData

Czyta dane dodatkowe XDATA
(cd:XDT_GetXData Ename App)
Argumenty:
Ename | [ENAME] | nazwa entycji
App | [STR] | nil = dla wszystkich aplikacji STR = dla aplikacji App
Zwraca:
Listę asocjacyjną danych dodatkowych lub nil
Przykład:
Polecenie: (cd:XDT_GetXData (car (entsel)) "CADPL")

("CADPL" (1000 . "X") (1070 . 5))
Powiązane z:
cd:XDT_PutXData
cd:XDT_RemoveXData


cd:XDT_PutXData

Dodaje dane dodatkowe XDATA
(cd:XDT_PutXData Ename App Data)
Argumenty:
Ename | [ENAME] | nazwa entycji
App | [STR] | nazwa aplikacji
Data | [LIST] | lista danych
Zwraca:
Listę asocjacyjną z danymi dodatkowymi
Przykład:
Polecenie: (cd:XDT_PutXData (car(entsel)) "CADPL" '((1000 . "X")(1070 . 5)))

((-1 . <Entity name: 7ef03430>) (0 . "CIRCLE") (330 . <Entity name: 7ef01cf8>) (5 . "1F6") (100 . "AcDbEntity") (67 . 0) (410 . "Model") (8 . "0") (100 . "AcDbCircle") (10 2193.86 631.418 0.0) (40 . 173.922) (210 0.0 0.0 1.0) (-3 ("CADPL" (1000 . "X") (1070 . 5))))
Powiązane z:
cd:XDT_GetXData
cd:XDT_RemoveXData


cd:XDT_RemoveXData

Usuwa dane dodatkowe XDATA
(cd:XDT_RemoveXData Ename App)
Argumenty:
Ename | [ENAME] | nazwa entycji
App | [STR] | nazwa aplikacji
Zwraca:
Listę asocjacyjną bez danych dodatkowych dla aplikacji App
Przykład:
Polecenie: (cd:XDT_RemoveXData (car (entsel)) "CADPL")

((-1 . <Entity name: 7ef03420>) (-3 ("CADPL")))
Powiązane z:
cd:XDT_GetXData
cd:XDT_PutXData